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CREATE A NEW ACCOUNT 
 
To access the 2010 ADEA AADSAS Admissions Officers portal, go to ADEA’s website, 
www.adea.org or go directly to 
www.adea.org/dental_education_pathways/aadsas/Pages/AdmissionsOfficers.aspx.  
 
First-Time Users Only 
To access the 2010 Dental School Admissions Officers Portal:  
 

1. Send an email to Jamesc@adea.org requesting permission to use the portal. 
 
2. ADEA AADSAS will request permission from the designated contact person for your 

institution.   
 

3. After permission is granted, you will receive an email with the subject line “2010 ADEA 
AADSAS DSAO Portal Login.”  Use the “Forgot Your Password?” feature to receive 
your new USERNAME and PASSWORD.   
• It is strongly recommended that after your initial login, you change your password 

to something easy for you to remember.   
 
Admissions Officers with Accounts  
 

Enter your USERNAME and PASSWORD in the web portal to log in to your dental 
school’s account.  

• If you have forgotten your password, enter the information in “Forgot Your 
Password?” and you will receive your account information immediately via email.  

 

 
 

http://www.adea.org/
http://www.adea.org/dental_education_pathways/aadsas/Pages/AdmissionsOfficers.aspx
mailto:Jamesc@adea.org
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My Profile > Account Information 
 

1) Your Account Information displays the information that was entered to set up your 
account with AADSAS.   
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My Profile > Account Information 
 
2) Change Password allows you to revise your Password:   

• Enter the Old Password (password that is currently being used) 
• Enter the New Password (what you would like the password to be) twice for 

confirmation   
• Click SAVE to retain the changes that were made   
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SET YOUR LOCAL STATUS 
 

Search > Set Local Status  
 
1) Set Local Status  

• Name of local status: allows you to search by any status you choose (for 
example, you can search by applicant last name).  You can enter all of your local 
statuses in this location.   

• Local status: allows you to write a description for each status (see page 14). 
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VIEW YOUR APPLICANTS’ INFORMATION 
 

Applicant 
 
Under My Tools > My Applicants and > Submitted Applicants. 
 

1) The Applicant Pool Status is a great tool to use on a daily basis.  The Applicant Pool 
Status provides a cumulative list and allows you to review applicants’ information 
through links.      

 

 
 

LEGEND 
 
The legend is color coded and specifies the status of each section in the Admissions Officers 
Portal.   
 

Applications In 
Progress: 

Applicant is working on the application and has not electronically 
delivered it to AADSAS.  These applicants have not yet 
submitted their applications but have indicated they will apply to 
your school.   

  
Applications 

Submitted: 
Applicant has electronically delivered the application to AADSAS.  
These applicants have applied to your school and can also be 
viewed by application processing status.   

  

Submitted 
Applicants: 
Allows you to 
produce an Excel 
spreadsheet 
showing all 
applicants in 
“unverified” status 
at any given time.   
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Applications 

Verified: 
Coursework has been verified and the GPA has been calculated. 
These applicants have applied to your school and can also be 
viewed by application processing status. 

  
Applications 

Mailed: 
Coursework has been verified, GPA has been calculated, and 
the paper application will be mailed to your school within 2 – 3 
weeks.  These applicants have applied to your school and can 
also be viewed by application processing status. 

  
Applications On-

Hold: 
AADSAS has placed the application on hold due to 
discrepancies in the application, payment, coursework, or 
transcripts.   

  
Applications 
Undelivered: 

AADSAS has returned the application to the applicant for 
corrections to the coursework section. 
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2) Search > Applicants will take you to an applicant’s application.  You can search for an 
applicant by name, AADSAS identification number, state of residency, admissions 
decision, local status, verified status, or academic update status. 
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2) Applications > Mailed lets you view each applicant’s information.   

 

 
 

 
DESCRIPTION OF TOOLBAR HEADINGS ON “APPLICATIONS > MAILED” SCREEN 

 
AADSAS ID: Each applicant has an identification number that begins with the entering 

class cycle, “2010.”   
  

Applicant: Click on this link and you can order names alphabetically. 
  

Date e-
Submitted: 

Click on this link to see applications in the order they were submitted to 
AADSAS.  This link can also be ordered by the date the application was 
submitted to AADSAS. 

  
Application 

Status: 
Lists various statuses for applicants: application status, date e-submitted, 
complete date, verified, local status, academic update, comments, 
revisions, mailings, and GPA.  

  
Payment: If the AADSAS application fee has been paid, a (check) appears. An (X) 

indicates no payment has been received.   
  

Documents 
Transcripts: 

Indicates the name of the college or university and the date(s) each 
transcript is received at AADSAS.  
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Documents 
Letters of 

Evaluation: 

This is the list of evaluators that has been supplied by the applicant:   
a. Date applicant entered the evaluator’s name 
b. Name of the evaluator 
c. School or institution name 
d. Type (paper or electronic) 
e. Waived (yes or no) 
f. Date Received – the date the letter was received by 

AADSAS  
g. Mailing # Date –  the date letters were mailed to designated 

dental schools 
h. View Evaluation  

 
(Letters of evaluation are sent to schools with applications, if received by 
the date AADSAS processes the application.  Letters received after the 
application has been sent are forwarded in the next mailing.) 

  
Local Status: Refer to page 14. 

  
Decisions: There are 13 decision codes schools can use to communicate application 

status changes to applicants. 
  

Supplemental 
Information: 

Admissions officers can use this option to communicate with applicants 
regarding items that have not been submitted or to convey comments.  
Information provided appears in the applicant portal.   

  
Mailing 

Number: 
The mailing number assigned when the application was mailed to the 
dental school.  

  
Print Profile: Permits you to print the applicant’s file (biographical and coursework 

information), including personal essay and additional information, on 8½ x 
11 paper.   
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DOWNLOAD AADSAS MAILINGS 
 

An automatic email notification is sent when a new mailing has been delivered to your portal.     
 
To securely download the electronic file, select View History from the Mailings option on the 
main menu of the portal.  A list of the AADSAS mailings appears, along with corresponding 
links to download the electronic files.   
 
The horizontal toolbar under Mailing History provides a list of mailings that have been 
generated by AADSAS. 
 

 
 

Mailing No: Select the mailing number to view the list of applicants including 
in that mailing.  

  
Date Created: Date the applicant created an account to complete an application. 

  
Electronic Release 

Date: 
The date the applicant’s application is available electronically. 

  
Scheduling Shipping 

Date: 
The date the application folders and materials are mailed to your 
dental school.  You should receive the hard copy in a few weeks. 

  
Total Number of 

Applicants: 
The total number of applicants per mailing. 

  
Folders - New: Count of new applications in the mailing. 

  
Folders - Revised: The total number of revised applications in the mailing (if any).  

  
Folders - Total: The total number of applications in the mailing. 

  
New References: Provides a count of letters of evaluation.  

  
Download File/Last 

download: 
See further instructions below for download file.  The last 
download displays the initials and date the file was downloaded at 
your school.   
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Download A Mailing 
 
1) Select the mailing you want to process. 
 
2) Save the file to your computer.  The file name will be your school abbreviation along with 

the mailing number (for example, AZ001.ZIP).   
 
3) The file stored on your computer is ZIPPED, so if you cannot open the file you may need 

to install PKZIP software on your computer. 
 

YOUR DOWNLOAD IS COMPLETE! 
 
View Latest Mailings shows all applicants included in the most recent mailing.  Detailed 
information and the option to print are available.   
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Print AADSAS File Folder Labels  
 
After accessing the 2010 AADSAS Dental School Admissions Officers portal from 
www.adea.org: 
 
 Under My Tools, in the Mailings section, click History. 
 
 A list of AADSAS mailings will display. Select the mailing you want to download and 

click Download File. You have the option to OPEN or SAVE the file. 
 
 Extract the Microsoft Word document from the zipped file; for example, USC001-

1.doc. 
 
 To access applicant file labels, open the appropriate Microsoft Word document. For 

example, the USC001-1.doc document contains applicant folder labels (one per 
applicant). 
 

 Click File > Print and choose Avery 5160 labels. 
 
 Use manila file folders with three tabs (left, center, or right).  

 
 Each label will contain the applicant’s AADSAS ID, name, and state of residence.  If 

the applicant chooses “NO STATE,” state of residence will appear as “ZZ” on the 
label. 

 
 
Print AADSAS Mailing Address Labels 
 
 
After accessing the 2010 AADSAS Dental School Admissions Officers portal from 
www.adea.org: 
 
 Under My Tools, in the Mailings section, select History. 

 
 A list of AADSAS mailings will display. Select the mailing you want to process and 

click Download File. You have the option to OPEN or SAVE the file. 
 
 To access mailing addresses, extract the appropriate Microsoft Word document from 

the zipped file. For example, choose USC001-6.doc to print six labels per page or 
USC001-12.doc to print 12 labels per page.   

 
 Click File > Print and choose Avery 5160 labels. 

 
 
 
 
 
 
 
 
 

 

http://www.adea.org/
http://www.adea.org/
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SET UP YOUR LOCAL INTERPRETATION 
 
Admissions Decisions  
 
This section of the Admissions Officers portal permits admissions officers to provide each 
applicant with updated information about the status of his or her application.  Through their 
portal, applicants are able to monitor admission status at each of the schools to which they 
have applied.  If you have AClient, you do not need to set up local interpretation (see AClient 
instructions).   
 

1) In the left toolbar on the home page, click Admissions > View All to view the 
admissions status of all applicants.  

 
2)   Select an Admissions Decision Code for the each applicant.     
 
3) Select SAVE. Each applicant is now able to see the admission status code, the local 

interpretation, and the date it was entered by the school.   
   

4)    Date Set will display the date the admission is set.   
 
5)    Set By will display the initials of the person who set the decision code.  
 
6)    Applicant Record will display the applicant’s complete application. 
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Set Local Interpretation 
 
Because admission status codes can have different meanings at each dental school, 
admissions officers are encouraged to provide a “local interpretation” for each status code.  
Local interpretation information is conveyed to the applicant, along with the particular status 
code.   
 
Local interpretation information is helpful to applicants, and may reduce the number and 
frequency of applicant phone calls and inquiries regarding application status. 
 
Several examples below show the kinds of messaging that can be included with “local 
interpretations.”   
 
Admissions officers are encouraged to provide explanations of their status codes.     
 

 
 

 
Example of possible local interpretations  
 
RR We have received your AADSAS application and are reviewing it now.  You will be 

contacted by our office regarding next steps.   
 
RW Follow-up information has been requested, and you will be contacted when your file is 

complete.  Allow two weeks from the date you submit information for your file to be 
considered complete.   
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ACLIENT USERS  
 

SEE DOWNLOAD INSTRUCTIONS AT  
http://www.academicmanagement.com/admit2010/CClient.htm 

 
 
 
 

http://www.academicmanagement.com/admit2010/CClient.htm
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 QUICK REFERENCES  
 

 
Applications Submitted 

 
Applications > Submitted shows all applicants who have e-submitted dental school 
applications to AADSAS.  
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Applications > Verified 

 
Verified Applications show all applicants whose coursework has been verified and whose 
GPA has been calculated.    
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Applications > On Hold 
 
ON HOLD shows a list of applicants placed on hold due to discrepancies in the 
application, payment, coursework, or transcript.  
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Application Status 
 

• Status – color code providing the status of an application 
• Date E-Submitted 
• Date Completed 
• Verified (yes or no) 
• Local Status 
• Academic Update  
• Comments 
• Revisions 
• Mailings 
• GPA 
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Supplemental Materials 
 
This section allows admissions officers to update an applicant’s file and make comments.   
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View Transcripts and Letters of Evaluation 
 
This section displays official documents received at AADSAS.     
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